Error Report

unread
Listings: 
Error Code: 
4
Error Message: 
Operation details
Installable Units Reported: 
org.springframework.ide.eclipse.security.feature.feature.group,3.6.4.201503051146-RELEASE
Detailed Message: 
Cannot complete the install because of a conflicting dependency. Software being installed: Spring IDE Roo Support 3.6.4.201503051146-RELEASE (org.springframework.ide.eclipse.roo.feature.feature.group 3.6.4.201503051146-RELEASE) Software currently installed: Eclipse IDE for Java Developers 1.4.1.20110909-1818 (epp.package.java 1.4.1.20110909-1818) Only one of the following can be installed at once: Refactoring Core 3.6.100.v20130605-1748 (org.eclipse.ltk.core.refactoring 3.6.100.v20130605-1748) Refactoring Core 3.4.2.r342_v20081028-0800 (org.eclipse.ltk.core.refactoring 3.4.2.r342_v20081028-0800) Refactoring Core 3.5.101.r362_v20101117-0800 (org.eclipse.ltk.core.refactoring 3.5.101.r362_v20101117-0800) Refactoring Core 3.5.201.r371_v20110824-0800 (org.eclipse.ltk.core.refactoring 3.5.201.r371_v20110824-0800) Refactoring Core 3.6.201.v20150819-1034 (org.eclipse.ltk.core.refactoring 3.6.201.v20150819-1034) Refactoring Core 3.5.201.r372_v20111101-0700 (org.eclipse.ltk.core.refactoring 3.5.201.r372_v20111101-0700) Refactoring Core 3.6.0.v20120523-1543 (org.eclipse.ltk.core.refactoring 3.6.0.v20120523-1543) Refactoring Core 3.5.100.v20100526-0800 (org.eclipse.ltk.core.refactoring 3.5.100.v20100526-0800) Refactoring Core 3.4.1.r341_v20080716-0800 (org.eclipse.ltk.core.refactoring 3.4.1.r341_v20080716-0800) Refactoring Core 3.5.200.v20110505-0800 (org.eclipse.ltk.core.refactoring 3.5.200.v20110505-0800) Refactoring Core 3.7.0.v20160419-0705 (org.eclipse.ltk.core.refactoring 3.7.0.v20160419-0705) Refactoring Core 3.5.0.v20090513-2000 (org.eclipse.ltk.core.refactoring 3.5.0.v20090513-2000) Refactoring Core 3.4.0.v20080603-2000 (org.eclipse.ltk.core.refactoring 3.4.0.v20080603-2000) org.eclipse.ltk.core.refactoring 3.2.1.r321_v20060823 Only one of the following can be installed at once: Search Support 3.5.0.v20090526-2000 (org.eclipse.search 3.5.0.v20090526-2000) Search Support 3.10.0.v20150318-0856 (org.eclipse.search 3.10.0.v20150318-0856) Search Support 3.6.0.v20100520-0800 (org.eclipse.search 3.6.0.v20100520-0800) Search Support 3.9.1.v20131121-1346 (org.eclipse.search 3.9.1.v20131121-1346) Search Support 3.4.1.r341_v20080813-0800 (org.eclipse.search 3.4.1.r341_v20080813-0800) Search Support 3.11.0.v20160519-1501 (org.eclipse.search 3.11.0.v20160519-1501) Search Support 3.7.0.v20110928-1504 (org.eclipse.search 3.7.0.v20110928-1504) Search Support 3.5.1.r351_v20090708-0800 (org.eclipse.search 3.5.1.r351_v20090708-0800) Search Support 3.8.0.v20120523-1540 (org.eclipse.search 3.8.0.v20120523-1540) Search Support 3.7.0.v20110505-0800 (org.eclipse.search 3.7.0.v20110505-0800) Search Support 3.11.1.v20161113-1700 (org.eclipse.search 3.11.1.v20161113-1700) Search Support 3.4.0.v20080603-2000 (org.eclipse.search 3.4.0.v20080603-2000) org.eclipse.search 3.2.1.r321_v20060726 Only one of the following can be installed at once: Text Editor Framework 3.6.0.v20100520-0800 (org.eclipse.ui.workbench.texteditor 3.6.0.v20100520-0800) Text Editor Framework 3.8.0.v20120523-1310 (org.eclipse.ui.workbench.texteditor 3.8.0.v20120523-1310) Text Editor Framework 3.10.1.v20160818-1626 (org.eclipse.ui.workbench.texteditor 3.10.1.v20160818-1626) Text Editor Framework 3.5.1.r352_v20100105 (org.eclipse.ui.workbench.texteditor 3.5.1.r352_v20100105) Text Editor Framework 3.7.0.v20110928-1504 (org.eclipse.ui.workbench.texteditor 3.7.0.v20110928-1504) Text Editor Framework 3.5.0.v20090603 (org.eclipse.ui.workbench.texteditor 3.5.0.v20090603) Text Editor Framework 3.4.1.r341_v20080827-1100 (org.eclipse.ui.workbench.texteditor 3.4.1.r341_v20080827-1100) Text Editor Framework 3.8.101.v20130729-1318 (org.eclipse.ui.workbench.texteditor 3.8.101.v20130729-1318) Text Editor Framework 3.10.0.v20160530-2011 (org.eclipse.ui.workbench.texteditor 3.10.0.v20160530-2011) Text Editor Framework 3.9.100.v20141023-1946 (org.eclipse.ui.workbench.texteditor 3.9.100.v20141023-1946) Text Editor Framework 3.7.0.v20110505-0800 (org.eclipse.ui.workbench.texteditor 3.7.0.v20110505-0800) Text Editor Framework 3.6.1.r361_v20100714-0800 (org.eclipse.ui.workbench.texteditor 3.6.1.r361_v20100714-0800) Text Editor Framework 3.4.0.v20080603-2000 (org.eclipse.ui.workbench.texteditor 3.4.0.v20080603-2000) org.eclipse.ui.workbench.texteditor 3.2.0.v20060605-1400 Cannot satisfy dependency: From: Eclipse IDE for Java Developers 1.4.1.20110909-1818 (epp.package.java 1.4.1.20110909-1818) To: org.eclipse.epp.package.java.feature.feature.group [1.4.1.20110909-1818] Cannot satisfy dependency: From: AspectJ Development Tools 2.2.4.e43yJ8-20140523-1400 (org.eclipse.ajdt.feature.group 2.2.4.e43yJ8-20140523-1400) To: org.eclipse.ajdt.ui [2.2.4.e43yJ8-20140523-1400] Cannot satisfy dependency: From: AspectJ Development Tools 2.2.4.e44x-20140516-1000 (org.eclipse.ajdt.feature.group 2.2.4.e44x-20140516-1000) To: org.eclipse.contribution.weaving.jdt [2.2.4.e44x-20140516-1000] Cannot satisfy dependency: From: AspectJ Development Tools UI 2.2.4.e43yJ8-20140523-1400 (org.eclipse.ajdt.ui 2.2.4.e43yJ8-20140523-1400) To: bundle org.eclipse.jdt.ui [3.8.0,4.9.0) Cannot satisfy dependency: From: JDT Weaving 2.2.4.e44x-20140516-1000 (org.eclipse.contribution.weaving.jdt 2.2.4.e44x-20140516-1000) To: bundle org.eclipse.ltk.core.refactoring [3.6.0,4.3.0) Cannot satisfy dependency: From: EPP Java Package 1.4.1.20110909-1818 (org.eclipse.epp.package.java.feature.feature.group 1.4.1.20110909-1818) To: org.eclipse.platform.feature.group [3.7.1.r37x_v20110729-9gF7UHOxFtniV7mI3T556iZN9AU8bEZ1lHMcVK] Cannot satisfy dependency: From: Java Development Tools UI 3.11.2.v20151123-1510 (org.eclipse.jdt.ui 3.11.2.v20151123-1510) To: bundle org.eclipse.search [3.10.0,4.0.0) Cannot satisfy dependency: From: Java Development Tools UI 3.12.0.v20160525-1829 (org.eclipse.jdt.ui 3.12.0.v20160525-1829) To: bundle org.eclipse.search [3.10.0,4.0.0) Cannot satisfy dependency: From: Java Development Tools UI 3.12.1.v20160822-0645 (org.eclipse.jdt.ui 3.12.1.v20160822-0645) To: bundle org.eclipse.search [3.10.0,4.0.0) Cannot satisfy dependency: From: Java Development Tools UI 3.12.2.v20160929-0804 (org.eclipse.jdt.ui 3.12.2.v20160929-0804) To: bundle org.eclipse.search [3.10.0,4.0.0) Cannot satisfy dependency: From: Java Development Tools UI 3.8.1.v20120814-144251 (org.eclipse.jdt.ui 3.8.1.v20120814-144251) To: bundle org.eclipse.ui.workbench.texteditor [3.8.0,4.0.0) Cannot satisfy dependency: From: Java Development Tools UI 3.9.2.v20131106-1600 (org.eclipse.jdt.ui 3.9.2.v20131106-1600) To: bundle org.eclipse.ui.workbench.texteditor [3.8.0,4.0.0) Cannot satisfy dependency: From: Java Development Tools UI 3.9.50.v20140317-1811 (org.eclipse.jdt.ui 3.9.50.v20140317-1811) To: bundle org.eclipse.ui.workbench.texteditor [3.8.0,4.0.0) Cannot satisfy dependency: From: Eclipse Platform 3.7.1.r37x_v20110729-9gF7UHOxFtniV7mI3T556iZN9AU8bEZ1lHMcVK (org.eclipse.platform.feature.group 3.7.1.r37x_v20110729-9gF7UHOxFtniV7mI3T556iZN9AU8bEZ1lHMcVK) To: org.eclipse.ltk.core.refactoring [3.5.201.r371_v20110824-0800] Cannot satisfy dependency: From: Eclipse Platform 3.7.1.r37x_v20110729-9gF7UHOxFtniV7mI3T556iZN9AU8bEZ1lHMcVK (org.eclipse.platform.feature.group 3.7.1.r37x_v20110729-9gF7UHOxFtniV7mI3T556iZN9AU8bEZ1lHMcVK) To: org.eclipse.search [3.7.0.v20110505-0800] Cannot satisfy dependency: From: Eclipse Platform 3.7.1.r37x_v20110729-9gF7UHOxFtniV7mI3T556iZN9AU8bEZ1lHMcVK (org.eclipse.platform.feature.group 3.7.1.r37x_v20110729-9gF7UHOxFtniV7mI3T556iZN9AU8bEZ1lHMcVK) To: org.eclipse.ui.workbench.texteditor [3.7.0.v20110505-0800] Cannot satisfy dependency: From: Spring IDE Roo Support 3.6.4.201503051146-RELEASE (org.springframework.ide.eclipse.roo.feature.feature.group 3.6.4.201503051146-RELEASE) To: org.eclipse.ajdt.feature.group 2.0.1