Enide Studio 2014 - Node.js, JavaScript, Java and Web Tools

Add this URL to your Eclipse Installation to reach this solution's update site.

Mars (4.5)
Luna (4.4)
Kepler (4.3)
Juno (4.2, 3.8)
Previous to Juno (<=4.1)
Neon (4.6)
Oxygen (4.7)
Photon (4.8)
2018-09 (4.9)


Learn more...

Details Group Tabs

Details

Nodeclipse "Enide Studio 2014" is Tool Suite for Node.js, JavaScript, Java Development.

This is the most feature-rich pack. Unless there is the latest version download for your OS,
recommended install via drag-n-drop of Install image onto Eclipse main toolbar


Check http://www.nodeclipse.org/ for your OS package.

Included plugins are
- Nodeclipse 1.0.1
- Chrome Development Tools, fixed for debugging Node.js
- AngularJS for Eclipse
- TernIDE
- Eclipse WTP WebResources
- TCF Terminals
- MarkDown (*.md) Editor
- GitHub Flavored Markdown (GFM) Viewer

- Eclipse 4.x Chrome Theme

- black Moonrise UI theme
- Nodeclipse EditBox
- JSHint Eclipse Integration 0.9.10
- RestClient Tool
- StartExplorer
- ZipEditor with some additions v1.1.2 to quickly look inside aar, apk, jar, war, zip, tar ... etc files
- Git Addon
- Nodeclipse Plugin List
- JDT Spelling
- Maven (install m2e if you need)
- Gradle (install Gradle integration for Eclispe if you need)
- Minimalist Gradle Editor
- Minimalist Jade Editor
- Nodeclipse EditBox
- ANSI Escape in Console
- YAML YEdit by http://dadacoalition.org/yedit
- Eclipse Color Theme released by Nodeclipse - Eclipse 3.x [mainly] Editors color themes, original author Felix H. Dahlke

- and of course standard Eclipse JDT, JSDT, EGit

See also Gradle IDE Pack

Older notes:

Enide Studio 2014 initially (version 0.11-preview) was released as stand-alone product for all OSes
and this marketplace entries to allow updates. (See also Enide - Eclipse Node.JS IDE for finer installation or if your Eclipse can't get JSDT or other standard plugins.)

Time showed as Windows user, I [Paul] could not also check if there are issues on other platforms, so only plugins distribution will follow. This may change if anyone would join as Linux/OS X lead.

You should install plugins in recent Eclipse distribution. Otherwise check individual plugins for there compatibility. E.g. Nodeclipse plugin should work with 3.x and 4.x Eclipse versions.

Check http://www.nodeclipse.org/ for the latest your OS package.

It is based on Eclipse Luna Standard and includes Nodeclipse 0.11 and other plugins for Node.js, JavaScript, Java and Eclipse development with git and GitHub.

Hints:
- try LOGpulse - A Log viewer based on impulse for performance analysis and profiling.

Additional Details
Eclipse Versions: 
Mars (4.5), Luna (4.4), Kepler (4.3), Juno (4.2, 3.8), Previous to Juno (<=4.1), Neon (4.6), Oxygen (4.7), Photon (4.8), 2018-09 (4.9)
Platform Support: 
Windows, Mac, Linux/GTK
Organization Name: 
Date Created: 
Fri, 2014-02-28 05:56
Development Status: 
Beta
License: 
EPL
Date Updated: 
Thu, 2018-08-23 15:07
Screenshots
Metrics
DateRankingInstallsClickthroughs
December 2018300/91679 (0.02%)9
November 2018302/939143 (0.02%)15
October 2018288/943164 (0.03%)9
September 2018260/941187 (0.04%)18
August 2018272/939191 (0.04%)7
July 2018273/940190 (0.04%)17
June 2018247/947222 (0.04%)10
May 2018261/954211 (0.04%)26
April 2018266/946210 (0.04%)11
March 2018307/961151 (0.03%)21
February 2018251/940204 (0.04%)12
January 2018278/945177 (0.04%)16
View Data for all Listings
Errors
External Install Button

Marketplace Drag to Install button

By adding the following code below to your website you will be able to add an install button for Enide Studio 2014 - Node.js, JavaScript, Java and Web Tools.

HTML Code:


Markdown Syntax:



Output: Drag to your running Eclipse* workspace. *Requires Eclipse Marketplace Client
Wednesday, December 19, 2018 - 06:28