Eclipse JST Server Adapters (Apache Tomcat, JOnAS, J2EE)

Add this URL to your Eclipse Installation to reach this solution's update site.

Mars (4.5)
Luna (4.4)
Kepler (4.3)
Juno (4.2, 3.8)
Previous to Juno (<=4.1)
Neon (4.6)
Oxygen (4.7)
Photon (4.8)
2018-09 (4.9)


Learn more...

Details Group Tabs

Details

This is quick way to install Eclipse JST Server Adapters and JST Server Adapters Extentions (Apache Tomcat, JOnAS, J2EE)

Currently Eclipse IDE for Java Developers is promoted download pinned to position #1.
A lot of Eclipse new users can find it confusing to add standard Tomcat support as it is within Eclipse IDE for Java EE Developers.

The purpose of the entry is to let them install with one drag-and-drop by integrating External Install button.

Example of such usage is Nodeclipse Plugins List

Notice for Users of Eclipse before Luna: Eclipse WTP has a lot of dependencies between projects. This entry is not update path, but for installation into Luna.

Additional Details
Eclipse Versions: 
Mars (4.5), Luna (4.4), Kepler (4.3), Juno (4.2, 3.8), Previous to Juno (<=4.1), Neon (4.6), Oxygen (4.7), Photon (4.8), 2018-09 (4.9)
Platform Support: 
Windows, Mac, Linux/GTK
Organization Name: 
Date Created: 
Thu, 2015-02-05 23:21
Development Status: 
Mature
License: 
EPL
Date Updated: 
Thu, 2018-08-23 15:03
Screenshots
Metrics
DateRankingInstallsClickthroughs
December 201872/902803 (0.27%)18
November 201871/9391574 (0.25%)26
October 201850/9432476 (0.39%)38
September 201870/9411423 (0.27%)21
August 201886/9391108 (0.22%)21
July 201882/9401289 (0.24%)21
June 201878/9471201 (0.24%)20
May 201882/9541225 (0.22%)17
April 201881/9461254 (0.23%)12
March 201884/9611248 (0.23%)3
February 201896/940908 (0.2%)21
January 201887/9451090 (0.22%)13
View Data for all Listings
Errors
External Install Button

Marketplace Drag to Install button

By adding the following code below to your website you will be able to add an install button for Eclipse JST Server Adapters (Apache Tomcat, JOnAS, J2EE).

HTML Code:


Markdown Syntax:



Output: Drag to your running Eclipse* workspace. *Requires Eclipse Marketplace Client
Monday, December 17, 2018 - 09:14
robberphex's picture

Only support to 8.0, not 8.5, not 9.0?

vlopatynsky's picture

I have the same problem, Please add Tomcat 8.5 support.

P.S. Does anyone know why STS 4 removed tomcat support from the box?