Early Security Vulnerability Detector - ESVD

Add this URL to your Eclipse Installation to reach this solution's update site.

Neon (4.6)
Mars (4.5)
Luna (4.4)
Kepler (4.3)
Juno (4.2, 3.8)
Previous to Juno (<=4.1)
Oxygen (4.7)


Learn more...

Details Group Tabs

ptrabocchi's picture

I've tried to install the project by marketplace client, but project update-site not found. The same for demo project or author home.

mcourcy's picture

Hi Luciano,

Working on linux I had some trouble in having the install button to work.
You may also add the plugin link directly

Another question, I see that your licence is EPL. Do you share your code somewhere, do you accept pull request ?

Thanks, I'm going to start the test

dmarner825's picture

I installed the plugin on eclipse for php version 4.4.1
I imported a php project which definitely has multiple vulnerabilitied. After enabling the the plugin, I got no feedback at all from the plugin. The Security Vulnerabilities Window stays empty. Switching between manual run and run on save did not change anything. sad.

lsouzajt6's picture

Sorry @dennis, the current version only works for Java. Because of what happened to you, I updated the description to let everybody know before downloading the plugin.

lsouzajt6's picture

I am not using any external libraries so if you are having problems during installation, I suggest updating Eclipse.

mmisingnameii7's picture

"http://" is missing in the Update Site URL.

lsouzajt6's picture

@Bertrand GILLIS,

Thank you! I fixed it.