Eclipse Foundation Member
Darkest Dark Theme & DevStyle

Add this URL to your Eclipse Installation to reach this solution's update site.

Oxygen (4.7)


Neon (4.6)


Learn more...

Details Group Tabs

sraybould's picture

Since "upgrading" from DarkestDark to DevStyle, things are no longer so dark anymore :-(
For example, #ifdef-ed out code had a black background before which was great but now it's got a yukky green background, so not dark at all.
This is just one example but I've noticed a few like this and must say that I preferred how it was before.

So how do I change these colours back to how they were in the "DarkestDark" theme?
Failing that, how do I remove DevStyle and go back to the orignial DarkestDark theme?

Thaks, Simon.

 

alara3bf's picture

Simon, Sorry our darkest dark (from DevStyle) is not as Dark as you expected. Do you mind sending some screenshots for the example you mentioned? If possible, you can you send them to our Support page for a better support and tracking.

On the other hand, with DevStyle you can always customize your theme and make it much darker. Just go to Window > Preferences > DevStyle > Color Theme and select "Dark Custom", then adgust L where higher value means darker (for dark themes). Additionally you can select a different Editor theme with darker background (and of course select "theme background") if you desire.

Hope this information helps.

Cheers!

mleone18t's picture

I prefer dark themes, and the ones in DevStyle look great, but with one significant problem. The drop-down arrows for unexpanded nodes in tree widgets have very little contrast relative to their background. At first glance, it looks like they're not even there. But if I look very closely, I can just make them out. When the node is expanded, the arrow is very light and so highly visible.

I tried available customizations, but I can't find a way to make the arrows sufficiently visible in a dark theme. Is there a customization I'm missing? If not, am I the only one having problems with this? If not, perhaps it can be addressed in a future release. I the arrows are dark to provide contrast between expanded and collapsed nodes, perhaps the colors can be reversed. When a node is expanded you already see the children (except when it's empty), so perhaps the hard-to-see arrows should be used when you already have other visual cues. Or better yet, provide contrasting arrow colors that both show up well against their background.

alara3bf's picture

Mark Leone, Thanks for reaching out! Can you please provide some screenshots of the issue you are describing, you can send them to our Support page for better tracking.

Also, issues like this are present when using Windows Classic theme (I'm talking about the overall OS theme) as SWT is not very customizable in such legacy themes. Are you by any chance using windows classic as your OS theme? if you are, swiching to a standard theme will fix the issue in dark themes.

Cheers! Aaron Lara

mleone18t's picture

Thanks for your reply, Aaron. I sent a screenshot with some further explanation to the support e-mail account.

I should have mentioned it, but this problem is occurring on MacOS. I installed DevStyle on my CentOS 7 system at work, and it looks great. The arrows are white, which gives them great contrast. On MacOS they're black, very nearly the same color as the background.

Since you asked about the OS theme, I tried changing the color profile on the DIsplay Preferences tab in MacOS, but it had no effect on drop-down arrow color or visibility. I cycled through all the profiles and there was no appreciable difference. If there are some other settings I can try on the Mac, I'll be glad to.

arico3wh's picture

Hello. It's a wonderfull looking theme. I want it!.

But, though I've tried, I cannot make it work on Kinetis Design Studio (KDS). This IDE is based on eclipse, then I understand that many core features requiered for 'Darkest Theme' may not be available. I don't know.

But, is there a way to make it work on this IDE?

alara3bf's picture

Alenjandro, Thanks for reaching out! DevStyle requires Eclipse Neon (4.6) as minimal version but Kinestis Design Studio is based on Eclipse 4.2.2. When KDS move to Neon, then you will be able to use DevStyle.

Cheers! Aaron Lara

yliuso8's picture

Version: Oxygen.1a Release (4.7.1a)

  “Light XXX” theme 。The main page up and down scroll bar, the wrong style.

“Dark XXX” theme is OK。

 

I come from China, the English expression may not be very good. thank you

bfernandestdp's picture

YiMing, thank you for your report - do you mind uploading a screenshot to elaborate? You can also create a post here with more details: https://www.genuitec.com/forums/topics/darkest-dark/

yliuso8's picture

-----photos.app.goo.gl/X5j34uOlPNubJd2W2

Show normal

----------

------photos.app.goo.gl/MbBRZIh8DpiAtBuf2

Abnormal display

bfernandestdp's picture

Thank you for taking the time to send in those screenshots. The narrower scrollbar in the view is by design. You did mention that the Dark theme is OK - we do use the same sort of scrollbar for the views there too (perhaps you missed it?)

mmisingname013's picture

Great plugin so far with a nice dark theme. But there are some glitches with Ubuntu. Since I haven't found an issue tracker, here they are:

1. when a dialog is open, the toolbar buttons turn to light gray (pasteboard.co/GWHzgaA.png)

2. the selected item in a tree or in a table has an orange background with a light gray for the text which is difficult to read (pasteboard.co/GWHBJpF.png).

3. Dropdown menus are weird (pasteboard.co/GWHCNrm.png)

bfernandestdp's picture

David, thank you for the kind words, we're glad you like our dark theme!

I'm afraid some of the GTK themes do not play well with the DevStyle theme. While we're looking into improving the behavior regardless of the OS theme selected, a workaround for now would be to choose a Dark-friendly GTK theme, like Adwaita or perhaps OSX-Arc-Darker. I think you may be on Ambiance which doesn't work too well.

A public issue tracker for theme related issues is here: https://www.genuitec.com/issue-tracker/

 

 

 

aheath3yp's picture

Ctrl-F now brings up Devstyle search dialog rather than the default Eclipse one but Ctrl-K (Eclipse Search find next) stills works using the previous Eclipse Search find string.

Confused me at first until I found the devstyle settings to turn off the inline search.

bfernandestdp's picture

Adrian, thank you for pointing that out. We overlooked the Find Next/Previous commands and we'll have them fixed in our next release.

Tip: Pressing Ctrl + F twice will bring up the regular search dialog, even if Inline Search is enabled.

avaish's picture

Is there any plan to release this awesome theme for Eclipse Mars.2(4.5.2) ?

:)

twebbcke's picture

Unfortunately that's not viable.  Due to some fundamentals of how DevStyle works, compatibility with Mars is a hard bar to pass.  Given this was already a significant undertaking to provide in Neon + Oxygen, and the smaller market of Mars users, it's hard to justify the investment for a free plugin!  We're glad you like it and hopefully your project work will allow you to move to Neon or Oxygen soon!

akelly3w2's picture

Well done, good job!

tweddlelmg's picture

Thanks, Aaron. You're comments are greatly appreciated. A lot of work has gone into this so it's very satisfying to get this sort of comment.

Tony, Genuitec

serdur's picture

Hi,

First of all thanks for the awesome theme.

There is one small thing about it which annoys me though. Editor background is not true black. It is dark greyish. Is it possible to make it true black?

Thanks

tweddlelmg's picture

Thanks for the comments, Serkan, they are much appreciated.

As far as the editor background color is concerned, do you have DevStyle enabled? If so, did you check the "Use editor theme background" option? If so, the default editor theme (Darkest Dark) will produce a very slightly lighter editor background. However, with Devstyle enabled, you do have more theming options and, for example, choosing the Sunburst theme and checking that option, mentioned above, you'll get a true black baground.

If you have further problems with this, please raise an issue on our Darkest Dark forum by clicking the Help icon ("?") on the plugin product page (above).

ewaldner's picture

Is there a way to restore the red highlight for build errors in the MCUXpresso IDE console using this theme? I installed the pluggin via Eclipse Marketplace Client 1.53 onto MCUXpresso IDE 10.0.2. Colors look great for editor and IDE in general, but errors are not displayed with colored highlighting or colored text, despite the settings showing the desired color scheme for build errors.

tweddlelmg's picture

Ed, thanks for your comments on Darkest Dark. It seems that the console you're referring to is the CDT console (which is also in the eclipse CPP package). In this case, you can set the various colors used by going to Window->Preferences->C/C++->Build->Console and setting the colors you want there. By default, Darkest Dark have set the background color to a deep black (on a generally grey console background).  I have tried changing colors here and the color settings are honored. If this is not your situation, could you please raise the issue on our forum (click the "?" icon above) and give us as much detail as possible about the problem (screenshots would also help).

mzajc's picture

The theme itself looks amazing!!!

Sadly, everytime I start Eclipse Photon (4.8.0), the javadoc background and fonts color are set to black. But when I uninstall Darkest Dark, it doesn't behave so.

 

Is there a solution for that other than uninstalling the theme? Please help!

tweddlelmg's picture

Marko, thanks for the comments. Unfortunately, we don't yet have an update site for Photon, so I guess you've installed the Oxygen version. Of course, we will be making this available for Photon but I don't have a schedule for that and Photon isn't yet released, though we're likely to have something that works before Photon is released in June 2018. I'm afraid that if you want to use Darkest Dark (DD), you'll probably have to revert to eclipse Oxygen. However, I checked DD on Linux Mint with Photon and didn't see the issue you mentioned. Could you mention which OS you're using, so we can check this issue when we start to test with Photon?

gsedov's picture

I have the same issue with oxygen. Every time I start eclipse some values are reverted to the wrong values. The ones I noticed are javadoc color and background (black), colored labels - match highlight (also black) and c/c++ editor text font (consolas regular 10).

All the affected items have a default of some sort (they are either "set to default" or "override default"). Seems like the plugin can't handle such items correctly.

To add strangeness to this behaviour: you can't simply "revert" the value - it does not save the reverted value. You first need to pick a new value, apply and save it, and only then the "revert" will restore the values intended by the theme.

bfernandestdp's picture

Are you using our light theme (now part of the 2017 CI 9 release) or dark theme? If you switch to the other, just to test, do you still experience these problems?

Unfortunately there are still some situations where the preferences just do not behave. The good news is that we believe we know why, and the next release will inclue a fix. Let us know if you would be interested in testing a pre-release with the fix, we'll let you know when it becomes available.

gsedov's picture

Just tried with light gray. Same result: black for colors, consolas regular 10 for font.

kmp53's picture

When I set the comment color,it is different from the actual display, such as set to (0,128,0), and is shown as (191,255,191).

 

tweddlelmg's picture

We're sorry that you are seeing this issue but thanks for reporting it. I see the same issue and I've raised a bug report for development to investigate.

kra4oa31rjmvw0o2's picture

I wasn't thrilled to open Eclipse to a popup asking me to try something out.

I clicked "agree" to checkout DevStyle and see what it is.

It adds some weird branded startup menu. Which does what?

Each time I open Eclipse, I have to select my workspace. It then takes several extra seconds to open the editor. Can you believe this? Eclipse already takes a while to open.

Granted, the ability to choose icon packs is nice, as is the theme itself as always. But I'm not interested in a foreign startup menu crapping up my development experience.

Dev, your theme is appreciated. Can we keep it to that?

bfernandestdp's picture

JW,

First, I'm glad you like the theme, thank you - if you haven't already tried them, DevStyle adds attractive light themes as well.

You can turn off the startup experience by clicking the "Use Classic Eclipse Startup Dialog" link in the bottom left of the Launch tab of the startup dialog, taking you back to the default Eclipse startup behavior, while keeping other parts of DevStyle enabled. We do realize this link is not too easy to find, and our next release will make it more obvious. You can also turn it off from the Darkest Dark preference page within the workbench.

The Enhanced Startup Experience gives you the ability to quickly locate resources you were working with, especially when you've been using multiple workspaces. In a subsequent release, we'll be adding simpler wizards that help you quickly start new projects across an array of technologies, and we'll add more features over time. Of course, we realize this won't be useful for everyone/everytime, so it's only an optional part of DevStyle - you can turn it off, while keeping the other features like light themes, inline find, and the breadcrumb toolbar still enabled. For more on the startup experience see this doc: https://www.genuitec.com/docs/workbench/using-devstyle-startup-experience/ and more on DevStyle in general, see here: https://www.genuitec.com/tech/devstyle

Hope this helps, thank you again for your comment.

junwu1981's picture

today, the theme pushed a update to my neon, it asked for restart, then my neon cannot start anymore.....

twebbcke's picture

Ouch!  Certainly not the expected nor usual behavior.  Mind sharing some details in our support forums such as error from configuration/13131313.log (different number of course)?  Thanks!

https://www.genuitec.com/forums/topics/darkest-dark/

dsfljkgaljk's picture

How can I fix that. I love the theme but without changing that its worse because that bar is so bright.

tweddlelmg's picture

Thanks for the comment, Dsfjkla Sfljkgaljk and for trying Darkest Dark!

This isn't a known problem but perhaps you could check for updates first and, if it still happens, let us know the details (including your OS and version and a screenshot) over at our support forum. We'd love to resolve this for you. Our forum can be reached by clicking on the support link icon above (the circle with "?" in it) then going to the Theme Problems forum.

sthompsonrj7's picture

I love this plugin!!!

My only complain is with cut and paste.  If I paste into something that maintains formatting (for example, Skype for Business which my company uses for instant messenger) I get all of these grays and pale blues against light blue backgrounds ... it is hardly legible. I don't know if there is any way to deal with that?

 

 

twebbcke's picture

What file type are you pasting into?  Normally coloring comes from the code syntax, not the actual paste buffer -- normally Eclipse takes the [plain text] format of the copy buffer.

Glad you like it!

sthompsonrj7's picture

I'm pasting into Micrsoft Office 2013.   This is really easy to reproduce ... using the default color scheme, go to an XML document like a POM, copy multiple lines of the POM to the clipboard, then paste it into MS Word.  The result is sky blue text pasted into a white document.

akarpyak's picture

Hello.

I have an issue in oxygen 64 version after installation.

In short, all sections in preferences are empty.  Actual sections on the left side are present, but right panel is empty for all sections.

bfernandestdp's picture

Andriy, apologies for the delayed response - I can't say we've seen something like this ever reported. What OS are you on? If Linux, what Windowing system and theme? Feel free to create a new topic on our forums: https://www.genuitec.com/forums/topics/darkest-dark/theme-problems/ for detailed assistance.

jbuchholz's picture

I install the dark theme and Eclipse Oxygen fails to start and crash with:


!ENTRY org.eclipse.osgi 4 0 2017-08-10 10:05:29.794
!MESSAGE Application error
!STACK 1
org.eclipse.swt.SWTError: Not implemented [multiple displays]
        at org.eclipse.swt.SWT.error(SWT.java:4559)
        at org.eclipse.swt.widgets.Display.checkDisplay(Display.java:821)
        at org.eclipse.swt.widgets.Display.create(Display.java:934)
        at org.eclipse.swt.graphics.Device.<init>(Device.java:174)
        at org.eclipse.swt.widgets.Display.<init>(Display.java:559)
        at org.eclipse.swt.widgets.Display.<init>(Display.java:550)
        at org.eclipse.ui.internal.Workbench.createDisplay(Workbench.java:781)

 

Uninstall it from console via

eclipse -application org.eclipse.equinox.p2.director -uninstallIU com.genuitec.eclipse.theming.feature.feature.group

twebbcke's picture

Odd!  If you could share the full stack over at our forums -- we'd love to have the details of this issue.  This doesn't seem like anything we've come across before.  Cheers!

https://www.genuitec.com/forums/topics/darkest-dark/theme-problems/

dcerisano's picture

I think your theme has cured my headache.

A much needed escape from Eclipse's stare-into-the-sun defaults.

 

 

 

eleonard4iq's picture

Trying it out and found a small annoying instance, if you copy & paste a class and are taken to the accept default name, or rename the class option, the suggested classname (whichever class you have copied with a suffix of 2 usually) will now have white text yet be highlighted with a babyblue colour background making it unreadable. If you then move the arrow key back, the baby blue background higlighting goes away but now you cannot see your cursor either. 

This makes it a little fidgety for this operation. functionally it works, but in UX terms it's not the nicest.

lsea's picture

Thank you so much! I have been looking at white UI and recogn eyes theme for so long! Now.. it. is. OVER! <3

I created an ccount just to post this! <3 <3

mcharestw5g's picture

Been using it for few days now and feel the need to mention how great it is.  After all these years seems like the beast of a task that is making a Dark theme under Eclipse has been tammed!

Big thanks.

ykihtan's picture

Some HI-DPI-monitor related isues on screenshot:

monosnap.com/file/2R7A1TGSTBybPuKYtF2WERJcJPeHKO

 

jngoo's picture

After installed the latest update, I constantly get a pop up message which is Java heap size, connection timeout on org.genuitec.theming.ui.

twebbcke's picture

Thanks for all the great reviews - for the support requests here, we'd strongly ask that you use our support forums as it makes it so much easier to get details, reply promptly, and more importantly, use the attachment feature.

https://www.genuitec.com/forums/topics/darkest-dark/theme-problems/