Angular Eclipse

Add this URL to your Eclipse Installation to reach this solution's update site.

Oxygen (4.7)
Neon (4.6)


Learn more...

Details Group Tabs

skkamaljava's picture

Hi, 

I tried to install Angular2 plugin for eclipse by the instructions from youtube videos.

There i got link to install ths plugin  "https://marketplace.eclipse.org/content/angular2-eclipse". But if i search for this link in browser i am not getting Angular2 related plugin.

Could you please assist.

 

Youtube search text : create angular2 project with eclipse IDE .

 

 

Thanks,

Kamal.

azerr's picture

I have renamed the marketplace from angular2 to angular, because it supports too angular4, angular5, etc.

You can install it with this marketplace (it will install 1.3.0). If you wish the not released version (1.4.0-SNAPSHOT) you can do it with update site https://github.com/angelozerr/angular-eclipse/wiki/Installation-Update-S...

pdhal's picture

when i create angularjs2 project. it shows  this message---- The 'C:/Users/Admin/AppData/Roaming/npm/ng.cmd' is not a ng file.

1-- Searching for global Angular CLI..

praveenkumarcss's picture

Angular4 proposals not displaying in Oxygen when I type Ctrl+space. Do I need to install any plugin?

azerr's picture

What do you mean with Angular4 proposals? Completion for what? inside HTML or TypeScript file? Please give more informations.

kkuhn's picture

Although the project compiles and runs, I frequently get the following error after saving code changes:

Eclipse popup:

Errors occurred during the build.
Errors running builder 'TypeScript Builder' on project 'test-app6'.
Error while compiling with tsserver
java.util.concurrent.TimeoutException
Error while compiling with tsserver
java.util.concurrent.TimeoutException

TIA
Kibu

 

azerr's picture

Same issue than https://github.com/angelozerr/typescript.java/issues/190 If you install 1.4.0-SNAPSHOT with update site (see https://github.com/angelozerr/angular-eclipse/wiki/Installation-Update-Site), this problem should disapear.

kkuhn's picture

I get typescript error messages in html files. Almost all tags are red underligned and marked as errors.

How to avoid that?

TIA

Kibu

azerr's picture

Your problem is because angular/@language-service is not very well integrated

 

I'm waiting for TypeScript fixes (see https://github.com/angular/vscode-ng-language-service/issues/43#issuecom...) to fix this problem. But you can fix this problem at hand by following https://github.com/angelozerr/angular-eclipse/issues/97#issuecomment-314...

bvandeputte's picture

hi,

I'm trying to install "angular2-eclipse" on Eclipse "Version: Neon.3 Release (4.6.3)"  under Windows 7 SP1 64Bits

 

I tried multiple times and always got this error:

 

An error occurred while collecting items to be installed
session context was:(profile=epp.package.java, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
Unable to read repository at (...)://oss.opensagres.fr/angular2-eclipse/1.2.0/plugins/ts.eclipse.ide.server.nodejs.embed.win32.win32.x86_64_1.2.0.201704141415.jar.
Premature end of Content-Length delimited message body (expected: 10753044; received: 7474690

 

(I removed htt p to comment here)

maybe 64bits package is invalid? how to fix it please

thanks, regards

bvandeputte's picture

fixed

was due to a temp proxy issue. Sorry for the noise ;)

hgoyalj01's picture

Can you please tell me how to remove temp proxy as i also got same problem?

jferraro's picture

This has many nice features for creating angular code and testing it, however, I'm losing my HTML intellisense after loading the plug-in.

azerr's picture

> I'm losing my HTML intellisense after loading the plug-in.

 

Which intellisense? Completion for w3c html tags inside HTML editor? Please creat ean issue at https://github.com/angelozerr/angular2-eclipse/issues by giving more info. Thanks!

mkellerour's picture

Please note that init (ng init) is no longer supported by the latest version of angular-cli. Both versions of the plugin don't work any longer. There is always an error during project creation.

azerr's picture

Please install 1.2.0-SNAPSHOT which fixes this problem by using (ng new).

mkellerour's picture

Hi Angelo

When I try to install 1.2.0-SNAPSHOT I got the following error:

Cannot complete the install because one or more required items could not be found.
Software being installed: TypeScript JSDT Integration 1.2.0.201703140717 (ts-jsdt-feature.feature.group 1.2.0.201703140717)
Missing requirement: TextMate support in Eclipse IDE - Core 0.1.0.201703140013 (org.eclipse.tm4e.core 0.1.0.201703140013) requires 'bundle org.jcodings 1.0.18' but it could not be found
Cannot satisfy dependency:
From: TextMate support in Eclipse IDE - UI 0.1.0.201703140013 (org.eclipse.tm4e.ui 0.1.0.201703140013)
To: bundle org.eclipse.tm4e.core 0.0.0
Cannot satisfy dependency:
From: TypeScript JSDT Integration 1.2.0.201703140717 (ts-jsdt-feature.feature.group 1.2.0.201703140717)
To: ts.eclipse.ide.jsdt.ui [1.2.0.201703140717]
Cannot satisfy dependency:
From: TypeScript - Eclipse - JSDT UI 1.2.0.201703140717 (ts.eclipse.ide.jsdt.ui 1.2.0.201703140717)
To: bundle org.eclipse.tm4e.ui 0.0.0

I have tried at two different PCs in two different networks, always the same. Did I choose the wrong version or URL for the update?

Thanks for your help

azerr's picture

drivasbsp's picture

Great plugin, easy to use and excellent free solution for Angular 2 development. However I'm using a dark theme for eclipse and the highlight color for ng directives in the HTML editor is dark blue by default. I cannot seem to find a hook in the preferences to change that color. Navigating to Preferences -> JavaScript -> TypeScript ->Angular2 ->HTML->Editor->Syntax Coloring first throws an error :"could Not Accept changes, The currently displayed page contains invalid values", but then shows up when trying again. Setting the options seem to have no effect, since the "Enable" checkbox is greyed out.

azerr's picture

Please try to install 1.2.0-SNAPSHOT with update site https://github.com/angelozerr/angular2-eclipse/wiki/Installation-Update-... and tell me if it fixes your issue. Otherwise please create an issue at https://github.com/angelozerr/angular2-eclipse/issues

dbal's picture

I tried to install again with a fresh install of Eclipse Neon. This time the error JavaScript errors disappeared. However, the tslint error is still there. How do I fix that error?

azerr's picture

tslint integration was a lot improved for 1.2.0 https://github.com/angelozerr/typescript.java/wiki/New-and-Noteworthy-1....

The release is not done but you can install it with Update Site https://github.com/angelozerr/typescript.java/wiki/Installation-Update-Site

dbal's picture

I am new to Angular 2, but I successfully ran the quickstart demo from angular.io. I have installed node.js and angular-cli. Regardless, I get many errors from a new Angular 2 project. I have 1 problem with TSLint and 4088 problems with JavaScript. I have no errors in the terminal from npm, but there is one warning (WARN deprecated minimatch@2.0.10: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue).

Any ideas what is wrong.

Also, it takes a couple of minutes to make a new empty project. Is that normal? Most of the time is spent on JavaScript validation.

Thanks for the help.

kperezxnu's picture

Dude, if this is a requirement to create Angualr2 projects, at least included as part of the installation process.

Everyone: Before creating an Angular2 project, be sure to do the following in a cmd window...

npm install -g angular-cli

Obviously, you must have nodejs installed.

azerr's picture

The 1.2.0 that you can install for the moment with Update Site https://github.com/angelozerr/angular2-eclipse/wiki/Installation-Update-... should fix this problem.

ugagliardelli's picture

I've just installed Eclipse Java EE IDE for Web Developers Neon.1 Release (4.6.1) and Angular2 Eclipse. I tried to create an Angular2 project but the console shows:
D:\Neon\ws\LogimatJs>ng init
"ng" non Š riconosciuto come comando interno o esterno,
un programma eseguibile o un file batch.
that means that ng was not found.
Where I'm wrong?

azerr's picture

The 1.2.0 that you can install for the moment with Update Site https://github.com/angelozerr/angular2-eclipse/wiki/Installation-Update-... should fix this problem.

ugagliardelli's picture

Yes, I did. But I solved this problem installing new node.js v6.7.0. For some reason, previous version v6.2.2 didn't suceed executing command npm install -g angular-cli.